Project

General

Profile

Bug #136

Localization issue

Added by Sylvain Laperche almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
05/29/2012
Due date:
% Done:

0%

Estimated time:

Description

In utils.c, function colortoint, we compare col against a localized string (color name).
The problem is strcmp doesn't work well with localisation. I saw a german translation is planned, it's a good example of problem that can happen.
White in german is Wei


Files

strcoll.patch (1.1 KB) strcoll.patch Sylvain Laperche, 05/29/2012 06:32 AM

History

#1

Updated by Robin Hahling almost 8 years ago

  • Target version set to 3.0.0
#2

Updated by Robin Hahling almost 8 years ago

I have yet to decide on this one. dfc can also be compiled with "NLS_ENABLED=false". In this case, keeping strcmp would probably be a better idea.

Maybe the solution would be not to translate the color values in the configuration file. I was wondering what the best solution would be about this because let's say "red" is not translated the same way in the *.pot file and the configuration file (a typo or anything else), then it will not be taken into account and will display a warning message.

What is your opinion on this?

#3

Updated by Robin Hahling almost 8 years ago

  • Status changed from New to Closed
  • Assignee set to Robin Hahling

Well, it is actually pretty fine even with NLS_ENABLED=false thus it has been applied. Thanks for the patch.

Also available in: Atom PDF